PÁGINA PBL

Metodología de la programación

Avisos:

 

Pseudocódigo
Pseudocódigo en PsEint

obtencadena(cad1,cad2 Por Referencia, n)
Inicio
  cad2<-""
  para i<-1 hasta n hacer
      cad2[i]<-cad1[i]
  FinPara
Fin

Entero buscar(cad1,cad2)
Inicio
  band<-1
  t<-longitud(cad1)
  para i<-1 hasta t Hacer
      si(cad1[i]<>cad2[i])Entonces
          band<-0
      FinSi
  FinPara
  retornar band
Fin

elimina(cad,cadnueva por referencia )
Inicio
  t<-longitud(cad)
  cadnueva<-""
  para i<-1 hasta t hacer
        cadnueva[i]<-cad[i+1]
  FinPara
Fin

Inicio //Algoritmo Principal
  escribir "da la cadena 1: "
  leer cad1
  escribir "Da la Subcadena a buscar: "
  leer cad2
  tamcad1<-longitud(cad1)
  tam<-longitud(cad2)
  band<-0
  Mientras (tamcad1>tam)
      obtencadena(cad1,cad3,tam)
      res<-buscar(cad3,cad2)
      si (res=1) Entonces
          band<-1
      FinSi
      elimina(cad1,cadnueva)
      tamcad1<-tamcad1-1
      cad1<-cadnueva
  finmientras
  si (band=1) Entonces
      Escribir "La Subcadena SI se ENCONTRO"
  Sino
      Escribir "La subcadena NO se ENCONTRO"
  FinSi
Fin

SubProceso obtencadena(cad1,cad2 Por Referencia, n)
cad2<-""
para i<-1 hasta n hacer
cad2<-cad2+subcadena(cad1,i,i)
FinPara
Fin SubProceso

SubProceso band<-buscar(cad1,cad2)
band<-1
t<-longitud(cad1)
para i<-1 hasta t Hacer
a<-subcadena(cad1,i,i)
b<-subcadena(cad2,i,i)
si(a<>b)Entonces
band<-0
FinSi
FinPara
Fin SubProceso

SubProceso elimina( cad, cadnueva por referencia )
t<-longitud(cad)
cadnueva<-""
para i<-2 hasta t hacer
cadnueva<-cadnueva+subcadena(cad,i,i)
FinPara
Fin SubProceso

Proceso sin_titulo
escribir "da la cadena 1: "
leer cad1
escribir "Subcadena a comparar: "
leer cad2
tamcad1<-longitud(cad1)
tam<-longitud(cad2)
band<-0
Mientras (tamcad1>tam)
//obtenemos una subcadena de la cadena //original
obtencadena(cad1,cad3,tam)
//escribir "subcadena a comparar = ",cad3
// verificamos si la subcadea obtenida es = a //la buscada
res<-buscar(cad3,cad2)
si (res=1) Entonces
band<-1
FinSi
//le quitamos un elemento a la cadena 1
elimina(cad1,cadnueva)
tamcad1<-tamcad1-1
cad1<-cadnueva
//escribir "nueva cadena =",cad1
finmientras
si (band=1) Entonces
Escribir "La Subcadena SI se ENCONTRO"
Sino
Escribir "La subcadena NO se ENCONTRO"
FinSi
FinProceso